as

Settings
Sign out
Notifications
Alexa
亚马逊应用商店
Ring
AWS
文档
Support
Contact Us
My Cases
新手入门
设计和开发
应用发布
参考
支持
跳转到主要内容

1.1 Update core dependencies

Replace the relevant sections of your package.json dependencies with the new versions for RN 0.83.
Required dependencies for RN83 The following dependencies are required for RN83:
  1. @react-native-community/cli: Keep version 20.0.0, which the Vega app template uses. @amazon-devices/kepler-cli-platform registers the react-native build-vega command through this package. Removing it causes npm run build:release to fail because react-native build-vega is an unrecognized command.
  2. jest dependencies:jest, babel-jest, ts-jest, and @types/jest must ALL be v29. Mixing v28 and v29 causes ERESOLVE unable to resolve dependency tree.
  3. react overrides: If you have an overrides section with "react", update it to "19.2.0":
Optional dependencies The following packages aren’t part of the Vega app template, and a standard app doesn’t need them. Add them only if your app uses them:
  • @react-native/new-app-screen (0.83.0): Only if your app renders the NewAppScreen component from the upstream React Native template.
  • react-native-safe-area-context (^5.5.2): Only if your app uses SafeAreaProvider or other components from this package.
  • @amazon-devices/keplerscript-commonmodules (^1.0.0): Only if your app uses JavaScript system bundling.

1.2 Update third-party packages

Update all third-party packages to their RN 0.83 compatible versions. See Supported Libraries and Services for the complete version table. To confirm which SDK versions ship RN 0.72 and RN 0.83, see the version compatibility matrix. Example of common packages

1.3 Additional library updates

Some libraries have new requirements for React Native 0.83:
  • react-native-reanimated requires react-native-worklets. If your app uses @amazon-devices/react-native-reanimated, you must also add @amazon-devices/react-native-worklets as a dependency. This is a new required runtime dependency in reanimated 4.0.0. Without it, the app crashes on launch with no clear error message.
  • @amazon-devices/shopify__flash-list is not compatible with RN 0.83. Use the upstream @shopify/flash-list@2.1.0 package directly instead. The wrapped version has a module resolution error in RN 0.83’s split-bundle system.
  • @amazon-devices/react-linear-gradient is not part of the RN 0.83 library set. Remove it and use the built-in experimental_backgroundImage style prop instead. See Replace LinearGradient with the backgroundImage style prop.
  • kepler-ui-components must be 3.0.0+. Version 2.x bundles its own copy of react-native with a transitive dependency, causing Jest test failures with Flow/ESM parse errors. This applies to all apps using kepler-ui-components, not just carousel users.

1.4 Install dependencies

Run npm install to receive all other dependencies.
最后修改于 2026年10月28日