1.1 Update core dependencies
Replace the relevant sections of yourpackage.json dependencies with the new versions for RN 0.83.
-
@react-native-community/cli: Keep version20.0.0, which the Vega app template uses.@amazon-devices/kepler-cli-platformregisters thereact-native build-vegacommand through this package. Removing it causesnpm run build:releaseto fail becausereact-native build-vegais an unrecognized command. -
jestdependencies:jest,babel-jest,ts-jest, and@types/jestmust ALL be v29. Mixing v28 and v29 causesERESOLVE unable to resolve dependency tree. -
reactoverrides: If you have anoverridessection with"react", update it to"19.2.0":
@react-native/new-app-screen(0.83.0): Only if your app renders theNewAppScreencomponent from the upstream React Native template.react-native-safe-area-context(^5.5.2): Only if your app usesSafeAreaProvideror other components from this package.@amazon-devices/keplerscript-commonmodules(^1.0.0): Only if your app uses JavaScript system bundling.
1.2 Update third-party packages
Update all third-party packages to their RN 0.83 compatible versions. See Supported Libraries and Services for the complete version table. To confirm which SDK versions ship RN 0.72 and RN 0.83, see the version compatibility matrix. Example of common packages1.3 Additional library updates
Some libraries have new requirements for React Native 0.83:-
react-native-reanimatedrequiresreact-native-worklets. If your app uses@amazon-devices/react-native-reanimated, you must also add@amazon-devices/react-native-workletsas a dependency. This is a new required runtime dependency in reanimated 4.0.0. Without it, the app crashes on launch with no clear error message. -
@amazon-devices/shopify__flash-listis not compatible with RN 0.83. Use the upstream@shopify/flash-list@2.1.0package directly instead. The wrapped version has a module resolution error in RN 0.83’s split-bundle system. -
@amazon-devices/react-linear-gradientis not part of the RN 0.83 library set. Remove it and use the built-inexperimental_backgroundImagestyle prop instead. See Replace LinearGradient with the backgroundImage style prop. -
kepler-ui-componentsmust be3.0.0+. Version 2.x bundles its own copy ofreact-nativewith a transitive dependency, causing Jest test failures with Flow/ESM parse errors. This applies to all apps usingkepler-ui-components, not just carousel users.
1.4 Install dependencies
Runnpm install to receive all other dependencies.

