Home > Devices

Using the Fire Tablet SDK

Deprecation Notice

As of Fire OS 5, the previously available Fire Tablet SDK add-on is deprecated. None of the components of the add-on are required to develop apps for Fire tablets. Use the Android API 22 (Lollipop) features and the Amazon Mobile Apps SDK for your apps. The content on this page is provided for legacy reference purposes only.

Introduction

You can add Firefly, Maps, and Device Messaging functionality to your app for Fire HDX 8.9 (4th Gen) tablets, by installing the Fire Tablet SDK add-on.

Resources in this Section

Setting Up Your Development Environment for Fire Tablets: Make sure you have the needed prerequisite software, then install and configure the Fire Tablets SDK.

Configuring Your Tablet Apps for the Fire Tablet SDK: Set up and configure your Android project and manifest to include the libraries and features from the Fire Tablet SDK.

Firefly API: Learn about Firefly plugins for Fire tablets and Fire Phone.

Maps API: Version 1 of the Maps API is included in the Fire Tablet SDK, to ensure compatibility with your existing apps. Use Version 2 of the Maps API to get the latest mapping functionality.

Amazon Device Messaging API: Learn how the ADM API, included with the Fire Tablet SDK add-on, lets you send push notifications from cloud devices that run your app.